Monday, October 10, 2011

LAB: BGP - Removed Private AS

- Reconfigure SW1 and SW3 in the private AS 65089 and adjust the peering settings accordingly.
- Create and advertise Loopback subnet in SW1 with the IP address 7.7.7.7/24.
- Configure AS 100 and AS 200 speakers to strip the private AS number when advertising the prefixes to AS 254 and AS 54.

configuration:

R2:
router bgp 200
neighbor 192.10.1.254 remove-private-as

R3:
router bgp 200
neighbor 155.1.37.7 remote-as 65089

R4:
router bgp 146
neighbor 204.12.1.254 remove-private-as

R6:

router bgp 146
neighbor 155.1.67.7 remote-as 65089
neighbor 54.1.1.254 remove-private-as

SW1:
router bgp 65089
neighbor 155.1.79.9 remote-as 65089
neighbor 155.1.67.6 remote-as 100
neighbor 155.1.37.3 remote-as 200
network 7.7.7.0 mask 255.255.255.0
!
interface Loopback1
ip address 7.7.7.7 255.255.255.0

SW3:
no router bgp 300
router bgp 65089
neighbor 155.1.79.7 remote-as 65089

verification:

Rack1R4#show ip bgp neighbors 204.12.1.254 adv
Rack1R4#show ip bgp neighbors 204.12.1.254 advertised-routes
BGP table version is 394, local router ID is 150.1.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 0.0.0.0          155.1.45.5                             0 200 i
*> 2.2.2.0/24       155.1.45.5                             0 200 i
*> 3.3.3.0/24       155.1.45.5                             0 200 i
*> 5.5.5.0/24       155.1.45.5               0             0 200 i
*> 7.7.7.0/24       155.1.45.5                             0 200 65089 i
*>i10.0.0.0/24      155.1.13.3               0    100      0 200 i
*> 10.0.0.0/22      155.1.45.5               0             0 200 i
*>i10.0.1.0/24      155.1.13.3               0    100      0 200 i
*>i10.0.2.0/24      155.1.13.3               0    100      0 200 i
*>i10.0.3.0/24      155.1.13.3               0    100      0 200 i
*> 155.1.0.0        0.0.0.0                            32768 i
*> 205.90.31.0      155.1.45.5                             0 200 254 ?
*> 220.20.3.0       155.1.45.5                             0 200 254 ?
*> 222.22.0.0       155.1.45.5                             0 200 i
*> 222.22.1.0       155.1.45.5                             0 200 i
*> 222.22.2.0       155.1.45.5                             0 200 254 ?

Total number of prefixes 16

RS.1.1.BB3>sho ip bgp
BGP table version is 298, local router ID is 31.3.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 2.2.2.0/24       204.12.1.4                             0 100 200 i
* i                 172.16.4.1               0    100      0 100 200 i
*> 3.3.3.0/24       204.12.1.4                             0 100 200 i
* i                 172.16.4.1               0    100      0 100 200 i
*> 5.5.5.0/24       204.12.1.4                             0 100 200 i
* i                 172.16.4.1               0    100      0 100 200 i
*> 7.7.7.0/24       204.12.1.4                             0 100 i
* i                 172.16.4.1               0    100      0 100 i
*> 10.0.0.0/24      204.12.1.4                             0 100 200 i
* i                 172.16.4.1               0    100      0 100 200 i
*> 10.0.0.0/22      204.12.1.4                             0 100 200 i
* i                 172.16.4.1               0    100      0 100 200 i
*> 10.0.1.0/24      204.12.1.4                             0 100 200 i
* i                 172.16.4.1               0    100      0 100 200 i
*> 10.0.2.0/24      204.12.1.4                             0 100 200 i
* i                 172.16.4.1               0    100      0 100 200 i
*> 10.0.3.0/24      204.12.1.4                             0 100 200 i
   Network          Next Hop            Metric LocPrf Weight Path
* i                 172.16.4.1               0    100      0 100 200 i
*> 28.119.16.0/24   0.0.0.0                  0         32768 i
*> 28.119.17.0/24   0.0.0.0                  0         32768 i
*>i112.0.0.0        172.16.4.1               0    100      0 i
*>i113.0.0.0        172.16.4.1               0    100      0 i
*>i114.0.0.0        172.16.4.1               0    100      0 i
*>i115.0.0.0        172.16.4.1               0    100      0 i
*>i116.0.0.0        172.16.4.1               0    100      0 i
*>i117.0.0.0        172.16.4.1               0    100      0 i
*>i118.0.0.0        172.16.4.1               0    100      0 i
*>i119.0.0.0        172.16.4.1               0    100      0 i
*> 155.1.0.0        204.12.1.4               0             0 100 i
* i                 172.16.4.1               0    100      0 100 i
* i205.90.31.0      172.16.4.1               0    100      0 100 200 254 ?
*>                  204.12.1.4                             0 100 200 254 ?
* i220.20.3.0       172.16.4.1               0    100      0 100 200 254 ?
*>                  204.12.1.4                             0 100 200 254 ?
*> 222.22.0.0       204.12.1.4                             0 100 200 i
* i                 172.16.4.1               0    100      0 100 200 i
*> 222.22.1.0       204.12.1.4                             0 100 200 i
* i                 172.16.4.1               0    100      0 100 200 i
* i222.22.2.0       172.16.4.1               0    100      0 100 200 254 ?
   Network          Next Hop            Metric LocPrf Weight Path
*>                  204.12.1.4                             0 100 200 254 ?

No comments:

Post a Comment