Wednesday, December 15, 2010

LAB: IPv6 network tunneled over IPv4 network

We can say that this type of implementation will be an interim solution when you're starting to build up your IPVv6 network. If some part of your network is still using IPv4, you can use tunneling in order for the IPv6 network able to reach the each other.

tulip setup:

ipv6 unicast-routing
!
!
interface Ethernet0/0
no ip address
full-duplex
ipv6 address FEC0:0:0:1::2/64
ipv6 rip flowerpot enable
!
!
ipv6 router rip flowerpot
!

daisy:
ipv6 unicast-routing
!
!
interface Tunnel0
description tunnel Daisy -> Rose
no ip address
ipv6 address FEC0:0:0:A::1/124
ipv6 rip flowerpot enable
tunnel source Ethernet0/0
tunnel destination 10.10.10.2
tunnel mode ipv6ip
!
interface Ethernet0/0
ip address 10.10.10.1 255.255.255.0
full-duplex
!
interface Ethernet0/1
no ip address
full-duplex
ipv6 address FEC0:0:0:1::1/64
ipv6 rip flowerpot enable
!
!
ipv6 router rip flowerpot
!

rose:
!
ipv6 unicast-routing
!
!
interface Tunnel0
description tunnel Rose -> Daisy
no ip address
ipv6 address FEC0:0:0:A::2/124
ipv6 rip flowerpot enable
tunnel source Ethernet0/0
tunnel destination 10.10.10.1
tunnel mode ipv6ip
!
interface Ethernet0/0
ip address 10.10.10.2 255.255.255.0
full-duplex
!
interface Ethernet0/1
no ip address
full-duplex
ipv6 address FEC0:0:0:2::1/64
ipv6 rip flowerpot enable
!
!
ipv6 router rip flowerpot
!

lily:

ipv6 unicast-routing
!
!
interface Ethernet0/0
no ip address
full-duplex
ipv6 address FEC0:0:0:2::2/64
ipv6 rip flowerpot enable
!
interface Ethernet0/1
no ip address
shutdown
half-duplex
!
!
ipv6 router rip flowerpot
!

VERIFICATION:
tulip#show ipv6 route
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
L FE80::/10 [0/0]
via ::, Null0
C FEC0:0:0:1::/64 [0/0]
via ::, Ethernet0/0
L FEC0:0:0:1::2/128 [0/0]
via ::, Ethernet0/0
R FEC0:0:0:2::/64 [120/3]
via FE80::CE05:29FF:FEB8:1, Ethernet0/0
R FEC0:0:0:A::/124 [120/2]
via FE80::CE05:29FF:FEB8:1, Ethernet0/0
L FF00::/8 [0/0]


lily#show ipv6 route
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
L FE80::/10 [0/0]
via ::, Null0
R FEC0:0:0:1::/64 [120/3]
via FE80::CE06:29FF:FEB8:1, Ethernet0/0
C FEC0:0:0:2::/64 [0/0]
via ::, Ethernet0/0
L FEC0:0:0:2::2/128 [0/0]
via ::, Ethernet0/0
R FEC0:0:0:A::/124 [120/2]
via FE80::CE06:29FF:FEB8:1, Ethernet0/0
L FF00::/8 [0/0]
via ::, Null0



tulip#TRACEROUTE IPV6 FEC0:0:0:2::2

Type escape sequence to abort.
Tracing the route to FEC0:0:0:2::2

1 FEC0:0:0:1::1 16 msec 12 msec 8 msec
2 FEC0:0:0:A::2 32 msec 12 msec 12 msec
3 FEC0:0:0:2::2 20 msec 28 msec 24 msec

Friday, October 29, 2010

LAB: Configuring Anycast RP


Anycast RP is a method of allowing the mapping of a single group to multiple RPs, RPs can be distributed throughout the domaint & use the same RP address resulting a creation of Virtual RP. MSDP is critical part to the creation of Virtual RP.



=============
CONFIGS
=============

ip multicast-routin
!
interface Loopback0
ip address 10.100.1.1 255.255.255.255
!
interface Loopback5
ip address 10.100.254.1 255.255.255.255
ip pim sparse-dense-mode
!
interface Ethernet0/0
ip address 10.10.0.1 255.255.255.252
full-duplex
!
interface Ethernet0/1
ip address 10.10.0.14 255.255.255.252
full-duplex
!
router ospf 1
router-id 10.100.1.1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 6500
bgp router-id 10.100.1.1
bgp log-neighbor-changes
neighbor Boogeymen peer-group
neighbor Boogeymen remote-as 6500
neighbor Boogeymen update-source Loopback0
neighbor 10.100.1.2 peer-group Boogeymen
neighbor 10.100.1.3 peer-group Boogeymen
neighbor 10.100.1.4 peer-group Boogeymen
!
address-family ipv4
neighbor 10.100.1.2 activate
neighbor 10.100.1.3 activate
neighbor 10.100.1.4 activate
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 multicast
neighbor 10.100.1.2 activate
neighbor 10.100.1.3 activate
neighbor 10.100.1.4 activate
no auto-summary
no synchronization
exit-address-family
!
ip http server
ip forward-protocol nd
!
!
ip pim send-rp-announce Loopback5 scope 20
ip pim send-rp-discovery Loopback5 scope 20
ip msdp peer 10.100.1.3 connect-source Loopback0
ip msdp description 10.100.1.3 to Mummy
ip msdp peer 10.100.1.2 connect-source Loopback0
ip msdp description 10.100.1.2 to Wolfman
ip msdp peer 10.100.1.4 connect-source Loopback0
ip msdp description 10.100.1.4 to Dracula
ip msdp originator-id Loopback0
ip msdp mesh-group Boogeymen 10.100.1.3
ip msdp mesh-group Boogeymen 10.100.1.2
ip msdp mesh-group Boogeymen 10.100.1.4
!
end


--------------------

hostname wolfman
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
interface Loopback0
ip address 10.100.1.2 255.255.255.255
!
interface Loopback5
ip address 10.100.254.1 255.255.255.255
ip pim sparse-dense-mode
!
interface Ethernet0/0
ip address 10.10.0.2 255.255.255.252
full-duplex
!
interface Ethernet0/1
ip address 10.10.0.5 255.255.255.252
full-duplex
!
router ospf 1
router-id 10.100.1.2
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 6500
bgp router-id 10.100.1.2
bgp log-neighbor-changes
neighbor Boogeymen peer-group
neighbor Boogeymen remote-as 6500
neighbor Boogeymen update-source Loopback0
neighbor 10.100.1.1 peer-group Boogeymen
neighbor 10.100.1.3 peer-group Boogeymen
neighbor 10.100.1.4 peer-group Boogeymen
!
address-family ipv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.3 activate
neighbor 10.100.1.4 activate
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 multicast
neighbor 10.100.1.1 activate
neighbor 10.100.1.3 activate
neighbor 10.100.1.4 activate
no auto-summary
no synchronization
exit-address-family
!
ip http server
ip forward-protocol nd
!
!
ip pim send-rp-announce Loopback5 scope 20
ip pim send-rp-discovery Loopback5 scope 20
ip msdp peer 10.100.1.1 connect-source Loopback0
ip msdp description 10.100.1.1 to Frankenstein
ip msdp peer 10.100.1.3 connect-source Loopback0
ip msdp description 10.100.1.3 to Mummy
ip msdp peer 10.100.1.4 connect-source Loopback0
ip msdp description 10.100.1.4 to Dracula
ip msdp originator-id Loopback0
ip msdp mesh-group Boogeymen 10.100.1.1
ip msdp mesh-group Boogeymen 10.100.1.3
ip msdp mesh-group Boogeymen 10.100.1.4
!
end


--------------------------

hostname mummy
!
!
interface Loopback0
ip address 10.100.1.4 255.255.255.255
!
interface Loopback5
ip address 10.100.254.1 255.255.255.255
ip pim sparse-dense-mode
!
interface Ethernet0/0
ip address 10.10.0.10 255.255.255.252
full-duplex
!
interface Ethernet0/1
ip address 10.10.0.13 255.255.255.252
full-duplex
!
router ospf 1
router-id 10.100.1.3
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 6500
bgp router-id 10.100.1.3
bgp log-neighbor-changes
neighbor Boogeymen peer-group
neighbor Boogeymen remote-as 6500
neighbor Boogeymen update-source Loopback0
neighbor 10.100.1.1 peer-group Boogeymen
neighbor 10.100.1.2 peer-group Boogeymen
!
address-family ipv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.2 activate
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 multicast
neighbor 10.100.1.1 activate
neighbor 10.100.1.2 activate
no auto-summary
no synchronization
exit-address-family
!
ip http server
ip forward-protocol nd
!
!
ip pim send-rp-announce Loopback5 scope 20
ip pim send-rp-discovery Loopback5 scope 20
ip msdp peer 10.100.1.1 connect-source Loopback0
ip msdp description 10.100.1.1 to Frankenstein
ip msdp peer 10.100.1.2 connect-source Loopback0
ip msdp description 10.100.1.2 to Wolfman
ip msdp originator-id Loopback0
ip msdp mesh-group Boogeymen 10.100.1.1
ip msdp mesh-group Boogeymen 10.100.1.2


---------------------

hostname dracula
!
ip multicast-routing
!
!
interface Loopback0
ip address 10.100.1.3 255.255.255.255
!
interface Loopback5
ip address 10.100.254.1 255.255.255.255
ip pim sparse-dense-mode
!
interface Ethernet0/0
ip address 10.10.0.6 255.255.255.252
full-duplex
!
interface Ethernet0/1
ip address 10.10.0.9 255.255.255.252
full-duplex
!
!
router ospf 1
router-id 10.100.1.4
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 6500
bgp router-id 10.100.1.4
bgp log-neighbor-changes
neighbor Boogeymen peer-group
neighbor Boogeymen remote-as 6500
neighbor Boogeymen update-source Loopback0
neighbor 10.100.1.1 peer-group Boogeymen
neighbor 10.100.1.2 peer-group Boogeymen
!
address-family ipv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.2 activate
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 multicast
neighbor 10.100.1.1 activate
neighbor 10.100.1.2 activate
no auto-summary
no synchronization
exit-address-family
!
ip http server
ip forward-protocol nd
!
!
ip pim send-rp-announce Loopback5 scope 20
ip pim send-rp-discovery Loopback5 scope 20
ip msdp peer 10.100.1.1 connect-source Loopback0
ip msdp description 10.100.1.1 to Frankenstein
ip msdp peer 10.100.1.2 connect-source Loopback0
ip msdp description 10.100.1.2 to Wolfman
ip msdp originator-id Loopback0
ip msdp mesh-group Boogeymen 10.100.1.1
ip msdp mesh-group Boogeymen 10.100.1.2
!
end


=====================
SHOW COMMANDS
=====================

frankenstein#show ip msdp peer
MSDP Peer 10.100.1.3 (?), AS 6500
Description: to Mummy
Connection status:
State: Up, Resets: 0, Connection source: Loopback0 (10.100.1.1)
Uptime(Downtime): 02:53:22, Messages sent/received: 174/174
Output messages discarded: 0
Connection and counters cleared 02:54:22 ago
Peer is member of mesh-group Boogeymen
SA Filtering:
Input (S,G) filter: none, route-map: none
Input RP filter: none, route-map: none
Output (S,G) filter: none, route-map: none
Output RP filter: none, route-map: none
SA-Requests:
Input filter: none
Peer ttl threshold: 0
SAs learned from this peer: 0
Input queue size: 0, Output queue size: 0
Message counters:
RPF Failure count: 0
SA Messages in/out: 0/0
SA Requests in: 0
SA Responses out: 0
Data Packets in/out: 0/0
MSDP Peer 10.100.1.2 (?), AS 6500
Description: to Wolfman
Connection status:
State: Up, Resets: 0, Connection source: Loopback0 (10.100.1.1)
Uptime(Downtime): 02:53:33, Messages sent/received: 174/174
Output messages discarded: 0
Connection and counters cleared 02:54:33 ago
Peer is member of mesh-group Boogeymen
SA Filtering:
Input (S,G) filter: none, route-map: none
Input RP filter: none, route-map: none
Output (S,G) filter: none, route-map: none
Output RP filter: none, route-map: none
SA-Requests:
Input filter: none
Peer ttl threshold: 0
SAs learned from this peer: 0
Input queue size: 0, Output queue size: 0
Message counters:
RPF Failure count: 0
SA Messages in/out: 0/0
SA Requests in: 0
SA Responses out: 0
Data Packets in/out: 0/0
MSDP Peer 10.100.1.4 (?), AS 6500
Description: to Dracula
Connection status:
State: Up, Resets: 0, Connection source: Loopback0 (10.100.1.1)
Uptime(Downtime): 02:53:36, Messages sent/received: 174/174
Output messages discarded: 0
Connection and counters cleared 02:54:37 ago
Peer is member of mesh-group Boogeymen
SA Filtering:
Input (S,G) filter: none, route-map: none
Input RP filter: none, route-map: none
Output (S,G) filter: none, route-map: none
Output RP filter: none, route-map: none
SA-Requests:
Input filter: none
Peer ttl threshold: 0
SAs learned from this peer: 0
Input queue size: 0, Output queue size: 0
Message counters:
RPF Failure count: 0
SA Messages in/out: 0/0
SA Requests in: 0
SA Responses out: 0
Data Packets in/out: 0/0
frankenstein# show ip pim rp

frankenstein# show ip pim rp ?
Hostname or A.B.C.D IP name or group address
mapping Show group-to-RP mappings
metric Show RP RPF metric
| Output modifiers


frankenstein# show ip pim rp mapping
PIM Group-to-RP Mappings
This system is an RP (Auto-RP)
This system is an RP-mapping agent (Loopback5)

Group(s) 224.0.0.0/4
RP 10.100.254.1 (?), v2v1
Info source: 10.100.254.1 (?), elected via Auto-RP
Uptime: 02:50:02, expires: 00:02:10



wolfman#show ip pim rp mapping
PIM Group-to-RP Mappings
This system is an RP (Auto-RP)
This system is an RP-mapping agent (Loopback5)

Group(s) 224.0.0.0/4
RP 10.100.254.1 (?), v2v1
Info source: 10.100.254.1 (?), elected via Auto-RP
Uptime: 02:47:45, expires: 00:02:31

mummy#show ip pim rp mapping
PIM Group-to-RP Mappings
This system is an RP (Auto-RP)
This system is an RP-mapping agent (Loopback5)

Group(s) 224.0.0.0/4
RP 10.100.254.1 (?), v2v1
Info source: 10.100.254.1 (?), elected via Auto-RP
Uptime: 02:45:16, expires: 00:01:59


dracula#show ip pim rp mapping
PIM Group-to-RP Mappings
This system is an RP (Auto-RP)
This system is an RP-mapping agent (Loopback5)

Group(s) 224.0.0.0/4
RP 10.100.254.1 (?), v2v1
Info source: 10.100.254.1 (?), elected via Auto-RP
Uptime: 02:43:54, expires: 00:02:16


Saturday, October 16, 2010

LAB: Connecting 2 PIM Domains seperated by IP Unicast only routing domain by using a Tunnel



Basically the concept is the same as my previous Post about the Multicast Load Sharing via Tunnel.

DIAGRAM

The diagram shows that 2 PIM domains are separated via a cloud of IP Unicast Domain. a tunnel is created between the 2 edge PIM routers.

config @ Godzilla

!
hostname Godzilla
!
ip multicast-routing
!
!
interface Tunnel0
ip unnumbered Ethernet0/0
ip pim sparse-dense-mode
tunnel source Ethernet0/0
tunnel destination 10.244.1.10
!
interface Ethernet0/0
ip address 10.244.1.1 255.255.255.0
full-duplex
!
interface Ethernet0/1
ip address 192.168.50.1 255.255.255.0
ip pim sparse-dense-mode
full-duplex
!
!
router ospf 1
log-adjacency-changes
passive-interface Tunnel0
network 10.0.0.0 0.255.255.255 area 0
network 192.168.0.0 0.0.255.255 area 0
!
ip http server
ip forward-protocol nd
!
!
ip pim send-rp-announce Ethernet0/1 scope 5
ip pim send-rp-discovery Ethernet0/1 scope 5
ip mroute 172.16.0.0 255.255.0.0 Tunnel0


config @ Mothra

!
hostname Mothra
!
!
ip multicast-routing
!
!
!
!
interface Tunnel0
ip unnumbered Ethernet0/0
ip pim sparse-dense-mode
tunnel source Ethernet0/0
tunnel destination 10.244.1.1
!
interface Ethernet0/0
ip address 10.244.1.10 255.255.255.0
full-duplex
!
interface Ethernet0/1
ip address 172.16.35.1 255.255.255.0
ip pim sparse-dense-mode
full-duplex
!
!
router ospf 1
log-adjacency-changes
passive-interface Tunnel0
network 0.0.0.0 255.255.255.255 area 0
!
ip mroute 192.168.0.0 255.255.0.0 Tunnel0
!

-----------------------------------
show commands
-----------------------------------

Godzilla#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 00:06:44/00:00:26, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Tunnel0, Forward/Sparse-Dense, 00:06:44/00:00:00

(192.168.50.1, 224.0.1.40), 00:01:27/00:02:32, flags: LT
Incoming interface: Ethernet0/1, RPF nbr 0.0.0.0
Outgoing interface list:
Tunnel0, Forward/Sparse-Dense, 00:01:32/00:00:00


Godzilla#show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
10.244.1.10 Tunnel0 00:03:14/00:01:27 v2 1 / S



Mothra#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 00:03:33/00:02:12, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Ethernet0/1, Forward/Sparse-Dense, 00:03:33/00:00:00

(192.168.50.1, 224.0.1.39), 00:00:59/00:02:00, flags: PT
Incoming interface: Tunnel0, RPF nbr 10.244.1.1, Mroute
Outgoing interface list: Null


Mothra#show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
10.244.1.1 Tunnel0 00:03:32/00:01:41 v2 1 / S

Mothra#mrinfo 192.168.50.1
192.168.50.1 [version 12.4] [flags: PMA]:
10.244.1.1 -> 10.244.1.10 [1/0/tunnel/pim]
192.168.50.1 -> 0.0.0.0 [1/0/pim/querier/leaf]

Mothra#mstat 192.168.50.1
Type escape sequence to abort.
Mtrace from 192.168.50.1 to 10.244.1.10 via RPF
From source (?) to destination (?)
Waiting to accumulate statistics......
Results after 10 seconds:

Source Response Dest Packet Statistics For Only For Traffic
192.168.50.1 10.244.1.10 All Multicast Traffic From 192.168.50.1
| __/ rtt 55 ms Lost/Sent = Pct Rate To 0.0.0.0
v / hop 55 ms --------------------- --------------------
192.168.50.1
10.244.1.1 ?
| ^ ttl 0
v | hop 0 ms -1/0 = --% 0 pps 0/0 = --% 0 pps
10.244.1.10 ?
| \__ ttl 1
v \ hop 0 ms 0 0 pps 0 0 pps
10.244.1.10 10.244.1.10
Receiver Query Source

Mothra#mtrace 192.168.50.1
Type escape sequence to abort.
Mtrace from 192.168.50.1 to 10.244.1.10 via RPF
From source (?) to destination (?)
Querying full reverse path...
0 10.244.1.10
-1 10.244.1.10 PIM/Static [192.168.0.0/16]
-2 10.244.1.1 PIM [192.168.50.0/24]
-3 192.168.50.1







Friday, October 15, 2010

LAB: Multicast Load Sharing via Tunnel




By creating a tunnel between the two equal paths to the same destination and making this tunnel a passive-interface (i.e OSPF) not allowing unicast traffic to use the tunnel for routing, but instead allowing only multicast traffic to use the tunnel.

note: PIM is not enabled on physical serial interfaces. only the tunnels and LAN ethernet interfaces are PIM enabled.




CONFIGS @ PORKPIE


hostname Porkpie
!
ip multicast-routing
!

!
interface Loopback0
ip address 10.244.1.3 255.255.255.255
ip pim sparse-mode
!
interface Tunnel0
ip address 10.244.2.2 255.255.255.252
ip pim sparse-dense-mode
tunnel source Loopback0
tunnel destination 10.244.1.4
!
interface Ethernet0/0
ip address 10.1.2.1 255.255.255.0
ip pim sparse-dense-mode
ip cgmp
full-duplex
!
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial1/0.605 point-to-point
ip address 10.2.4.1 255.255.255.0
frame-relay interface-dlci 605
!
interface Serial1/0.609 point-to-point
description pvc to stetson
ip address 10.2.3.2 255.255.255.0
frame-relay interface-dlci 609
!
!
router ospf 1
log-adjacency-changes
passive-interface Tunnel0
network 10.0.0.0 0.255.255.255 area 0
!
!
ip mroute 10.244.1.4 255.255.255.255 Tunnel0
ip mroute 10.1.1.88 255.255.255.255 Tunnel0
!
end

CONFIGS @ HOMBURG



hostname Homburg
!
ip multicast-routing
!
!
interface Loopback0
ip address 10.244.1.4 255.255.255.0
ip pim sparse-mode
!
interface Tunnel0
ip address 10.244.2.1 255.255.255.252
ip pim sparse-dense-mode
tunnel source Loopback0
tunnel destination 10.244.1.3
!
interface Serial0/0
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial0/0.305 point-to-point
ip address 10.2.1.1 255.255.255.0
frame-relay interface-dlci 305
!
interface Serial0/0.309 point-to-point
ip address 10.2.2.1 255.255.255.0
frame-relay interface-dlci 309
!
!
interface Ethernet1/0
ip address 10.1.1.1 255.255.255.0
ip pim sparse-dense-mode
ip cgmp
full-duplex
!
!
router ospf 1
log-adjacency-changes
passive-interface Tunnel0
network 10.0.0.0 0.255.255.255 area 0
!
!
ip pim send-rp-announce Loopback0 scope 5
ip pim send-rp-discovery scope 5
!
!
end
=========================================

SHOW COMMANDS

show ip route shows that it is using serial interfaces to reach the multicast source 10.1.1.88

Porkpie# show ip route 10.1.1.88
Routing entry for 10.1.1.0/24
Known via "ospf 1", distance 110, metric 138, type intra area
Last update from 10.2.3.1 on Serial1/0.609, 00:09:05 ago
Routing Descriptor Blocks:
* 10.2.4.2, from 10.244.1.2, 00:09:05 ago, via Serial1/0.605
Route metric is 138, traffic share count is 1
10.2.3.1, from 10.244.1.2, 00:09:05 ago, via Serial1/0.609
Route metric is 138, traffic share count is 1

also for Homburg lo0 10.244.1.4

Porkpie# show ip route 10.244.1.4
Routing entry for 10.244.1.4/32
Known via "ospf 1", distance 110, metric 129, type intra area
Last update from 10.2.3.1 on Serial1/0.609, 00:09:18 ago
Routing Descriptor Blocks:
10.2.4.2, from 10.244.1.2, 00:09:18 ago, via Serial1/0.605
Route metric is 129, traffic share count is 1
* 10.2.3.1, from 10.244.1.2, 00:09:18 ago, via Serial1/0.609
Route metric is 129, traffic share count is 1


for multicast routing, it is also unable to identify the incoming interface for the multicast group.

Porkpie#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 228.13.20.216), 00:47:07/stopped, RP 10.244.1.4, flags: SJC
Incoming interface: Null, RPF nbr 0.0.0.0, Mroute
Outgoing interface list:
Ethernet0/0, Forward/Sparse-Dense, 00:13:09/00:02:05

(10.1.1.88, 228.13.20.216), 00:08:46/00:00:38, flags: J
Incoming interface: Null, RPF nbr 0.0.0.0, Mroute
Outgoing interface list:
Ethernet0/0, Forward/Sparse-Dense, 00:08:46/00:02:05
th

PIM neighbor table shows that PIM is established between the two routers, but the problem is the returning packets back to 10.244.2.1 since Porkpie when returning the multicast packet back to Homburg, is using its unicast routing table to reach 10.244.2.1 via serial interfaces and not the tunnel this is due to tunnel0 is in passive-mode. so when the packets from 10.1.1.88 arrive on the tunnel interface the RPF check fails.

PIM Neighbor Table

Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
10.244.2.1 Tunnel0 00:10:42/00:01:25 v2 1 / S

RPF check fails

*Mar 1 00:54:46.871: IP(0): s=10.244.1.4 (Tunnel0) d=228.13.20.26 id=3738, ttl=3, prot=17, len=48(48), RPF lookup failed for source
*Mar 1 00:54:46.879: IP(0): s=10.244.1.4 (Tunnel0) d=228.13.20.26 id=3738, ttl=3, prot=17, len=48(48), not RPF interface


SOLUTION:

adding a static multicast route @ porkpie will solve this return multicast traffic.

ip mroute 10.244.1.4 255.255.255.255 Tunnel0
ip mroute 10.1.1.88 255.255.255.255 Tunnel0

after adding the static mroute command

Porkpie#show ip mroute 228.13.20.216
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode


(*, 228.13.20.216), 01:02:00/stopped, RP 10.244.1.4, flags: SJC
Incoming interface: Tunnel0, RPF nbr 10.244.2.1, Mroute
Outgoing interface list:
Ethernet0/0, Forward/Sparse-Dense, 00:28:01/00:02:12

(10.1.1.88, 228.13.20.216), 00:02:32/00:00:27, flags: JT
Incoming interface: Tunnel0, RPF nbr 10.244.2.1, Mroute
Outgoing interface list:
Ethernet0/0, Forward/Sparse-Dense, 00:02:32/00:02:12