Wednesday, October 5, 2011

LAB: BGP - Aggregation

- Configure R2 with four new Loopback interfaces with the IP addresses 10.0.0.1/24, 10.0.1.1/24, 10.0.2.1/24, and 10.0.3.1/24.
• Advertise an aggregate route for these networks that does not overlap any address space.

configuration

interface Loopback 100
ip address 10.0.0.1 255.255.255.0
!
interface Loopback 101
ip address 10.0.1.1 255.255.255.0
!
interface Loopback 102
ip address 10.0.2.1 255.255.255.0
!
interface Loopback 103
ip address 10.0.3.1 255.255.255.0
!
router bgp 200
network 10.0.0.0 mask 255.255.255.0
network 10.0.1.0 mask 255.255.255.0
network 10.0.2.0 mask 255.255.255.0
network 10.0.3.0 mask 255.255.255.0
aggregate-address 10.0.0.0 255.255.252.0


verification:

Rack1R2#show ip bgp 10.0.0.0/22
BGP routing table entry for 10.0.0.0/22, version 71
Paths: (1 available, best #1, table Default-IP-Routing-Table)
Flag: 0x820
  Advertised to update-groups:
     1          2        
  Local, (aggregated by 200 150.1.2.2)
    0.0.0.0 from 0.0.0.0 (150.1.2.2)
      Origin IGP, localpref 100, weight 32768, valid, aggregated, local, atomic-aggregate, best

Rack1R2#show ip route 10.0.0.0 255.255.252.0
Routing entry for 10.0.0.0/22
  Known via "bgp 200", distance 200, metric 0, type locally generated
  Routing Descriptor Blocks:
  * directly connected, via Null0
      Route metric is 0, traffic share count is 1
      AS Hops 0

No comments:

Post a Comment