Saturday, April 2, 2011

notes: GRE

Generic Routing Encapsulation:

IP Protocol 47
Used to transport payload protocols over IPv4 network
Payload can be..
- IPv4
- IPv6
- IPx
- NetBEUI

- Create tunnel interface
- tunnel no doesnt need to match on both ends.

- Define source and destination

tunnel source [ ip | interface]
tunnel destination [ip]


- apply payload protocols
- ip address
- ipv6 address

GRE Recursive Failure
- % TUN-5-RECURDON: Tunnel0 temporarily disabled due to recursive routing

- tunnel destination must not recurse to the tunnel interface itself
- This can happen due to metric or distance

Solution:

never advertise the tunnel destination across the tunnel

i.e.

if R1

10.10.1.0/24 - is the source network for the tunnel, dont advertise this in the routing protocol.

router rip
distribute-list
distribute-list prefix STOP_RECURSIVE_ERROR out Tunnel0
!
ip prefix-list STOP_RECURSIVE_ERROR seq 5 deny 10.10.1.0/24
ip prefix-list STOP_RECURSIVE_ERROR seq 10 permit 0.0.0.0/0 le 32


for R2

10.10.2. 0/24 - is the source network for the tunnel, dont advertise this in the routing protocol.

router rip
distribute-list
distribute-list prefix STOP_RECURSIVE_ERROR out Tunnel0
!
ip prefix-list STOP_RECURSIVE_ERROR seq 5 deny 10.10.2.0/24
ip prefix-list STOP_RECURSIVE_ERROR seq 10 permit 0.0.0.0/0 le 32


- or by not accepting that incoming route via the tunnel.

R2

access-list 20 deny 10.10.1.0
access-list 20 permit any
!
router rip
distribute-list 20 in tunnel 0



- or by creating a static route with better administrative distance using other egress interface and not the tunnel.


command tools

debug ip routing

No comments:

Post a Comment