Sunday, April 3, 2011

notes: General Routing

Network command:

- used to designate which networks a routing protocol will advertise
- indicates which interfaces will send and receive routing updates and form neighbor relationship (varies by protocol)
- BGP is an exception to this logic.

- interface has an IP of 10.1.1.1/24
- these statements all accomplish the same thing;
network 10.0.0.0 0.255.255.255
network 10.1.0.0 0.0.255.255.
network 10.1.1.0 0.0.0.255
network 10.1.1.1 0.0.0.0
- will it make it a difference in advertisement - no


Network Command and masking

i.e 172.16.1.1/24, 172.16.2.1/24, 172.16.3.1/24, 172.16.4.1/24

network 172.16.0.0 0.0.252.255 area 0

will cover how many interfaces

first 3 subnets if the mask is 0.0.3. 255

answer: match only 172.16.4.0

all interfaces:

network 0.0.0.0 255.255.255.255 area 0

single interfaces can still be different

network 171.6.1.1 0.0.0.0 area 12

specific commands overrides general


Passive Interfaces

- prevents routing udpates from being sent on a link but not received.
- network will still be advertised.
- prevents OSPF, EIGRP, and IS-IS neighhor relationships from being formed.
- can use passive-interface default.

Split Horizon

- prevents routing updates from being sent on an interface in which it was received.
- needs to be disabled for point-to-multipoint hub routers in frame relay
- cannot be disabled for all routing protocols
- OSPF does not use split horizon


Secondary Addresses

- if you have interfaces with more than one IP address and you want to run a routing protocol, there may be issues.
- primary ip must be advertised first
- split horizon is likely to have an effect
- cant use passive-interface for primary ip
- when sending updates the source ip always use the primary ip address

solution: split-horizon + validate update-source


Unnumbered interfaces
- used to conserve addresses
- used to mimic another interfaces
- watch connectivity problems of two unrelated address/subnets trying to share a common link
-PPP alleviates this with "peer neighbor-route"


ie - using different subnet i.e. 11.1.1.0/24 10.1.1.0/24 - using PPP its ok using peer neighbor-route


Routing Protocols and Bandwidth

- like QoS features, routing protocols look at interface bandwidht
- assumptions are made
- Bandwidth command can alter
- Method of influencing this without making changes directly inside the routing protocol.

Admin Distance

- determines which routing protocol has preference if a router receives the same route from two different protocols.
- distance can be altered globally on a router
- Distance can be altered for specific routes

router rip
distance 60

router ospf 1
distance ospf external 80 inter 110 intra 110

- this does donot anything, it always choose first intra inter then external
this only says that if external LSA wins the ospf rib electin then give administrative distance of 80 to make it preferred over EIGRP, if it doesnt win inter will have 110.


Distance command:

- access-list 11 permit 1.1.1.1 0.0.0.0
- access-list 11 permit 192.168.255.0 0.0.0.255

router ospf 1
distance 1909 208.158.37.100 0.0.0.0 11

- acl 11 is the routes to change
- 208.158.37.100 is the neighbor for the route

note for ospf - the source of the routes may not be directly connected neighbor.


Routes to Null0

- if the routes to null0 are generated by the routing protocol, these are specifically ALLOWED to appear.
- if you are manually keying in the routes, these are not allowed at all.
- aggregate-address and summary-address commands will routinely add null0 routes to the routing table.

No comments:

Post a Comment