Thursday, March 17, 2011

LAB: Reliable PBR



Requirements:

- Configure R1 and R5 to run CDP over the Frame Relay network with each
other.
- Configure an IP SLA instance on R1 that pings R4’s connection to VLAN
146 every five seconds.
- Configure policy routing on R1 so that traffic from R3 going to R4’s
Loopback0 network is sent to R5 over the Frame Relay link, while traffic to
R5’s Loopback0 network is sent to R4 over VLAN 146.
- Use traceroute to verify that this configuration is functional.
- Modify the R1’s policy routing so that if R1 loses R5 as a CDP neighbor
traffic from R3 to R4’s Loopback0 network is rerouted directly to R4.
- Modify the R1’s policy routing so that if R1 loses ICMP reachability to R4
traffic from R3 to R5’s Loopback0 network is rerouted directly to R5.
- Use traceroute to verify that this configuration is functional.



R1:

ip sla monitor 1
type echo protocol ipIcmpEcho 155.1.146.4 source-interface
FastEthernet0/0
timeout 2000
frequency 5
!
ip sla monitor schedule 1 life forever start-time now
!
track 1 rtr 1
!
interface Serial0/0
ip address 155.1.0.1 255.255.255.0
encapsulation frame-relay
cdp enable
frame-relay map ip 155.1.0.5 105 broadcast
no frame-relay inverse-arp
!
interface Serial0/1
ip policy route-map RELIABLE_POLICY_ROUTING
!
ip access-list extended FROM_R3_TO_R4_LOOPBACK
permit ip host 155.1.13.3 host 150.1.4.4
!
ip access-list extended FROM_R3_TO_R5_LOOPBACK
permit ip host 155.1.13.3 host 150.1.5.5
!
route-map RELIABLE_POLICY_ROUTING permit 10
match ip address FROM_R3_TO_R4_LOOPBACK
set ip next-hop 155.1.0.5
set ip next-hop verify-availability --------------using CDP
set ip default next-hop 155.1.146.4
!
route-map RELIABLE_POLICY_ROUTING permit 20
match ip address FROM_R3_TO_R5_LOOPBACK
set ip next-hop verify-availability 155.1.146.4 1 track 1 ---using ICMP SLA Monitor
set ip default next-hop 155.1.0.5

No comments:

Post a Comment