Thursday, March 17, 2011

LAB: GRE Tunneling and Recursive Routing


A recursive routing error is when a lookup for prefix X points at prefix Y, and a
lookup for prefix Y points at prefix X. For tunnel interfaces this occurs when the
tunnel destination is dynamically learned in the tunnel interface itself. This
problem can be easily identified by the IOS log message %TUN-5-
RECURDOWN: Tunnel0 temporarily disabled due to recursive routing.

problem:

With the reception of a new RIP route for 150.1.9.0/24 with a metric of 1, the old route with a metric of 5 is flushed out. The recursive error now occurs because 150.1.9.0/24 is reachable via 10.34.0.9, but 10.34.0.9 is the tunnel reachable via 150.1.9.9. The router detects this error, disables the tunnel, and all routes learned via the tunnel are flushed.

%LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state
to up

RT: del 150.1.9.0/24 via 155.1.108.8, rip metric [120/5]
RT: SET_LAST_RDB for 150.1.9.0/24
OLD rdb: via 13.11.13.11
RT: SET_LAST_RDB for 150.1.9.0/24
NEW rdb: via 10.34.0.9
RT: add 150.1.9.0/24 via 10.34.0.9, rip metric [120/1]


Solution:


SW3:

ip routing
!
interface Tunnel0
ip address 10.34.0.9 255.255.255.0
tunnel source Loopback0
tunnel destination 150.1.10.10
!
interface Loopback1
ip address 172.16.0.9 255.255.255.255
!
ip route 172.16.0.10 255.255.255.255 Tunnel0
!
router rip
version 2
no auto-summary
network 10.0.0.0
network 150.1.0.0
network 155.1.0.0
distribute-list prefix STOP_RECURSIVE_ERROR out Tunnel0
!
ip prefix-list STOP_RECURSIVE_ERROR seq 5 deny 150.1.9.0/24
ip prefix-list STOP_RECURSIVE_ERROR seq 10 permit 0.0.0.0/0 le 32


SW4:

ip routing
!
interface Tunnel0
ip address 10.34.0.10 255.255.255.0
tunnel source Loopback0
tunnel destination 150.1.9.9
!
interface Loopback1
ip address 172.16.0.10 255.255.255.255
!
ip route 172.16.0.9 255.255.255.255 Tunnel0
!
router rip
version 2
no auto-summary
network 10.0.0.0
network 150.1.0.0
network 155.1.0.0

distribute-list prefix STOP_RECURSIVE_ERROR out Tunnel0
!
ip prefix-list STOP_RECURSIVE_ERROR seq 5 deny 150.1.10.0/24
ip prefix-list STOP_RECURSIVE_ERROR seq 10 permit 0.0.0.0/0 le 32

No comments:

Post a Comment