Saturday, February 12, 2011

notes: EtherChannel

EtherChannel
- bundles redundant links and treat them as a single link to achieving substantial
bandwidth and redundancy benefits.

-Notice that EtherChannel affects STP because ordinarily one or more of the links would be disabled to prevent a loop.

Guidelines for EtherChannel:
1. All Ethernet interfaces on all modules must support EtherChannel.
2. You have a maximum of eight interfaces per EtherChannel.
3. The ports do not need to be contiguous or on the same module.
4. All ports in the EtherChannel must be set for the same speed and duplex.
5. Enable all interfaces in the EtherChannel.
6. An EtherChannel will not form if one of the ports is a Switched Port Analyzer (SPAN) destination.
7. For Layer 3 EtherChannels, assign a Layer 3 address to the port-channel logical interface, not the physical interfaces.
8. Assign all EtherChannel ports to the same VLAN or ensure they are all set to the same trunk encapsulation and trunk mode.
9. The same allowed range of VLANs must be configured on all ports in an EtherChannel.
10. Interfaces with different STP port path costs can form an EtherChannel.
11. After an EtherChannel has been configured, a configuration made to the physical interfaces affects the physical interfaces only.

EtherChannel load balancing can use MAC addresses, IP addresses, or Layer 4 port numbers—either source, destination, or both source and destination addresses.


Etherchannel Load-Balancing options command:

port-channel load-balance {mode}

dst-ip Destination IP Address.
dst-mac Destination MAC Address(Default for IPv4 and non-IP traffic).
src-dst-ip Source XOR Destination IP Address.
src-dst-mac Source XOR Destination MAC Address.
src-ip Source IP Address (Default for IPv6 traffic).
src-mac Source MAC Address.


EtherChannel Modes:

1. On - no negotiation/non dynamic
2. PagP - cisco proprietary
- desirable - send
- auto - listen
3. LACP - ieee 802.3ad
-active - send
-passive - listen


layer 2 EtherChannel configuration set:

int range fa0/1-2
shutdown
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
no shut
!
interface port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk

layer 2 EtherChannel configuration set:

int range fa0/1-2
shutdown
no switchport
channel-group 1 mode active
!
int Port-Channel1
ip address 1.1.1.1 255.255.255.0
!
int range fa0/1-2
no shutdown

verification command:

show etherchannel summary

SU - for layer 2/in used
RU - for layer 3/in used

No comments:

Post a Comment